Get in touch
Back
Maintenance

Backend Database Maintenance

Completed 3 Oct at 04:13pm CEST.

xHP Flashtool API xHP Backend xHP Pro Webapp
Completed

Database maintenance completed!

Posted 3 Oct at 04:13pm CEST.
Started

The xHP Backend is currently unavailable due to database migration.

Posted 3 Oct at 04:03pm CEST.